thunar-volman-0.8.1.ebuild 959 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="Daemon that enforces volume-related policies"
  6. HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
  7. SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86"
  11. IUSE="debug libnotify"
  12. COMMON_DEPEND=">=dev-libs/glib-2.30
  13. virtual/libgudev:=
  14. >=x11-libs/gtk+-2.24:2
  15. >=xfce-base/exo-0.10
  16. >=xfce-base/libxfce4ui-4.10
  17. >=xfce-base/libxfce4util-4.10
  18. >=xfce-base/xfconf-4.10
  19. libnotify? ( >=x11-libs/libnotify-0.7 )"
  20. RDEPEND="${COMMON_DEPEND}
  21. virtual/udev
  22. >=xfce-base/thunar-1.6[udisks]"
  23. DEPEND="${COMMON_DEPEND}
  24. dev-util/intltool
  25. sys-devel/gettext
  26. virtual/pkgconfig"
  27. pkg_setup() {
  28. XFCONF=(
  29. $(use_enable libnotify notifications)
  30. $(xfconf_use_debug)
  31. )
  32. DOCS=( AUTHORS ChangeLog NEWS README THANKS )
  33. }