xfce4-cellmodem-plugin-0.0.5.ebuild 987 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EAUTORECONF=yes
  5. inherit multilib xfconf
  6. DESCRIPTION="A panel plug-in with monitoring support for GPRS/UMTS(3G)/HSDPA(3.5G) modems"
  7. HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-cellmodem-plugin"
  8. SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="debug"
  13. RDEPEND="sys-apps/pciutils
  14. virtual/libusb:0
  15. >=xfce-base/libxfcegui4-4.8
  16. >=xfce-base/xfce4-panel-4.8"
  17. DEPEND="${RDEPEND}
  18. dev-util/intltool
  19. virtual/pkgconfig"
  20. pkg_setup() {
  21. PATCHES=(
  22. "${FILESDIR}"/${P}-asneeded.patch
  23. "${FILESDIR}"/${P}-link_for_xfce_warn.patch
  24. "${FILESDIR}"/${P}-build.patch
  25. )
  26. XFCONF=(
  27. --libexecdir="${EPREFIX}"/usr/$(get_libdir)
  28. $(use_enable debug)
  29. )
  30. DOCS=( AUTHORS ChangeLog README )
  31. }
  32. src_prepare() {
  33. echo panel-plugin/cellmodem.desktop.in.in > po/POTFILES.skip
  34. xfconf_src_prepare
  35. }