xfce4-mailwatch-plugin-1.2.0.ebuild 970 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
  6. HOMEPAGE="http://spuriousinterrupt.org/projects/xfce4-mailwatch-plugin/"
  7. SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE="debug ipv6 ssl"
  12. RDEPEND=">=dev-libs/glib-2:=
  13. >=x11-libs/gtk+-2.18:2=
  14. x11-libs/libX11:=
  15. >=xfce-base/exo-0.7.2
  16. >=xfce-base/libxfce4ui-4.10:=
  17. >=xfce-base/libxfce4util-4.10:=
  18. >=xfce-base/xfce4-panel-4.10
  19. ssl? (
  20. dev-libs/libgcrypt:0=
  21. >=net-libs/gnutls-2:=
  22. )"
  23. DEPEND="${RDEPEND}
  24. dev-util/intltool
  25. sys-devel/gettext
  26. virtual/pkgconfig"
  27. pkg_setup() {
  28. XFCONF=(
  29. $(use_enable ssl)
  30. $(use_enable ipv6)
  31. $(xfconf_use_debug)
  32. )
  33. DOCS=( AUTHORS ChangeLog NEWS README TODO )
  34. }