xfce4-netspeed-plugin-0.3.1.ebuild 787 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib xfconf
  5. DESCRIPTION="A network transfer rate monitoring panel plug-in, inspired by Gnome's Netspeed applet"
  6. HOMEPAGE="https://code.google.com/p/xfce4-netspeed-plugin/"
  7. SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm64 x86"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/glib-2:=
  13. >=gnome-base/libgtop-2:=
  14. x11-libs/gtk+:2=
  15. >=xfce-base/libxfce4ui-4.8:=
  16. >=xfce-base/libxfce4util-4.8:=
  17. >=xfce-base/xfce4-panel-4.8:="
  18. DEPEND="${RDEPEND}
  19. dev-util/intltool
  20. sys-devel/gettext
  21. virtual/pkgconfig"
  22. S=${WORKDIR}/${PN}
  23. pkg_setup() {
  24. XFCONF=(
  25. --libexecdir="${EPREFIX}"/usr/$(get_libdir)
  26. )
  27. DOCS=( AUTHORS README )
  28. }