xfce4-whiskermenu-plugin-1.6.0.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils gnome2-utils
  5. DESCRIPTION="Alternate application launcher for Xfce"
  6. HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin"
  7. SRC_URI="https://github.com/gottcode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm x86"
  11. IUSE=""
  12. RDEPEND="
  13. virtual/libintl:=
  14. x11-libs/gtk+:2=
  15. xfce-base/exo:=
  16. xfce-base/garcon:=
  17. xfce-base/libxfce4ui:=
  18. xfce-base/libxfce4util:=
  19. xfce-base/xfce4-panel:="
  20. DEPEND="${RDEPEND}
  21. sys-devel/gettext
  22. virtual/pkgconfig"
  23. src_prepare() {
  24. local i
  25. cd po || die
  26. if [[ -n "${LINGUAS+x}" ]] ; then
  27. for i in *.po ; do
  28. einfo "removing ${i%.po} linguas"
  29. has ${i%.po} ${LINGUAS} || { rm ${i} || die ; }
  30. done
  31. fi
  32. cmake-utils_src_prepare
  33. }
  34. src_configure() {
  35. local mycmakeargs=(
  36. -DENABLE_AS_NEEDED=OFF
  37. -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
  38. -DENABLE_DEVELOPER_MODE=OFF
  39. )
  40. cmake-utils_src_configure
  41. }
  42. pkg_preinst() {
  43. gnome2_icon_savelist
  44. }
  45. pkg_postinst() {
  46. gnome2_icon_cache_update
  47. }
  48. pkg_postrm() {
  49. gnome2_icon_cache_update
  50. }