123456789101112131415161718192021222324252627282930313233343536373839 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
- HOMEPAGE="https://sourceforge.net/projects/joe-editor/"
- SRC_URI="mirror://sourceforge/joe-editor/${P}.tar.gz"
- LICENSE="GPL-1+ CC-BY-3.0"
- SLOT="0"
- KEYWORDS="alpha amd64 arm ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
- IUSE="xterm"
- DEPEND=">=sys-libs/ncurses-5.2-r2"
- RDEPEND="xterm? ( >=x11-terms/xterm-239 )"
- DOCS=( README.md NEWS.md docs/hacking.md docs/man.md )
- src_prepare() {
- default
- # Enable xterm mouse support in the rc files
- if use xterm; then
- cd "${S}"/rc
- for i in *rc*.in; do
- sed -e 's/^ -\(mouse\|joexterm\)/-\1/' -i "${i}" || die "sed failed"
- done
- fi
- }
- pkg_postinst() {
- if use xterm; then
- elog "To enable full xterm clipboard you need to set the allowWindowOps"
- elog "resources to true. This is usually found in /etc/X11/app-defaults/XTerm"
- elog "This is false by default due to potential security problems on some"
- elog "architectures (see bug #91453)."
- fi
- }
|