xlsx2csv-0.6.ebuild 530 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="xml"
  6. inherit distutils-r1
  7. DESCRIPTION="Convert MS Office xlsx files to CSV"
  8. HOMEPAGE="https://github.com/dilshod/xlsx2csv/"
  9. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. DEPEND="dev-lang/perl"
  14. python_compile_all() {
  15. emake -C man
  16. }
  17. python_install_all() {
  18. distutils-r1_python_install_all
  19. doman man/${PN}.1
  20. }