gazebo-8.0.0.ebuild 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils versionator vcs-snapshot flag-o-matic
  5. DESCRIPTION="A 3D multiple robot simulator with dynamics"
  6. HOMEPAGE="http://gazebosim.org/"
  7. SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
  8. LICENSE="Apache-2.0"
  9. # Subslot = major version = soname of libs
  10. SLOT="0/8"
  11. KEYWORDS="~amd64"
  12. IUSE="cpu_flags_x86_sse2 libav test"
  13. RDEPEND="
  14. >=dev-libs/protobuf-2:=
  15. virtual/opengl
  16. media-libs/openal
  17. net-misc/curl
  18. dev-libs/tinyxml
  19. dev-libs/tinyxml2
  20. dev-libs/libtar
  21. dev-cpp/tbb
  22. >=dev-games/ogre-1.7.4[freeimage]
  23. >=media-libs/freeimage-3.15.4[png]
  24. sci-libs/libccd
  25. libav? ( >=media-video/libav-9:0= )
  26. !libav? ( >=media-video/ffmpeg-2.6:0= )
  27. sci-libs/gts
  28. >=sci-physics/bullet-2.82
  29. >=dev-libs/sdformat-5.0:=
  30. dev-qt/qtwidgets:5
  31. dev-qt/qtcore:5
  32. dev-qt/qtopengl:5
  33. dev-libs/boost:=[threads]
  34. sci-libs/gdal
  35. virtual/libusb:1
  36. dev-libs/libspnav
  37. media-libs/freeimage
  38. sci-libs/hdf5:=
  39. sys-apps/util-linux
  40. media-gfx/graphviz
  41. net-libs/ignition-msgs:=
  42. >=sci-libs/ignition-math-2.3:3=
  43. net-libs/ignition-transport:3=
  44. x11-libs/qwt:6=[qt5]
  45. "
  46. DEPEND="${RDEPEND}
  47. dev-qt/qttest:5
  48. app-text/ronn
  49. app-arch/gzip
  50. virtual/pkgconfig
  51. x11-apps/mesa-progs
  52. test? ( dev-libs/libxslt )
  53. "
  54. CMAKE_BUILD_TYPE=RelWithDebInfo
  55. PATCHES=( "${FILESDIR}/qwt.patch" "${FILESDIR}/tests.patch" )
  56. src_configure() {
  57. # doesnt build without it
  58. append-cxxflags "-std=c++11"
  59. # doesnt build with as-needed either
  60. append-ldflags "-Wl,--no-as-needed"
  61. local mycmakeargs=(
  62. "-DUSE_UPSTREAM_CFLAGS=OFF"
  63. "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
  64. "-DUSE_HOST_CFLAGS=FALSE"
  65. "-DBUILD_TESTING=$(usex test TRUE FALSE)"
  66. "-DENABLE_SCREEN_TESTS=FALSE"
  67. "-DUSE_EXTERNAL_TINYXML2=TRUE"
  68. )
  69. cmake-utils_src_configure
  70. }