wayv-0.3-r2.ebuild 627 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="Wayv is hand-writing/gesturing recognition software for X"
  6. HOMEPAGE="http://www.stressbunny.com/wayv"
  7. SRC_URI="http://www.stressbunny.com/gimme/wayv/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc x86"
  11. RDEPEND="
  12. x11-libs/libX11
  13. x11-libs/libXtst
  14. "
  15. DEPEND="
  16. ${RDEPEND}
  17. x11-proto/inputproto
  18. x11-proto/xproto
  19. "
  20. src_prepare() {
  21. sed -i -e 's| = -Wall -O2| += |g' src/Makefile* || die
  22. tc-export CC
  23. }
  24. src_install() {
  25. default
  26. cd doc
  27. default
  28. dodoc HOWTO*
  29. }