libwpg-0.2.2.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit alternatives eutils
  5. DESCRIPTION="C++ library to read and parse graphics in WPG"
  6. HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
  8. LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
  9. SLOT="0.2"
  10. KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="doc static-libs"
  12. RDEPEND="app-text/libwpd:0.9[tools]"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig
  15. doc? ( app-doc/doxygen )"
  16. RDEPEND="${RDEPEND}
  17. !<app-text/libwpd-0.1.3-r1"
  18. src_configure() {
  19. econf \
  20. --disable-werror \
  21. --program-suffix=-${SLOT} \
  22. --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
  23. $(use_with doc docs) \
  24. $(use_enable static-libs static)
  25. }
  26. src_install() {
  27. default
  28. prune_libtool_files --all
  29. }
  30. pkg_postinst() {
  31. alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
  32. alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
  33. alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
  34. }
  35. pkg_postrm() {
  36. alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
  37. alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
  38. alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
  39. }