12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849 |
- # Copyright 1999-2014 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit alternatives eutils
- DESCRIPTION="C++ library to read and parse graphics in WPG"
- HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
- LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
- SLOT="0.2"
- KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- IUSE="doc static-libs"
- RDEPEND="app-text/libwpd:0.9[tools]"
- DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
- RDEPEND="${RDEPEND}
- !<app-text/libwpd-0.1.3-r1"
- src_configure() {
- econf \
- --disable-werror \
- --program-suffix=-${SLOT} \
- --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
- $(use_with doc docs) \
- $(use_enable static-libs static)
- }
- src_install() {
- default
- prune_libtool_files --all
- }
- pkg_postinst() {
- alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
- }
- pkg_postrm() {
- alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
- }
|