123456789101112131415161718192021222324252627282930313233343536 |
- # Copyright 1999-2014 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- inherit autotools eutils
- DESCRIPTION="Flexible filesystem archiver for backup and deployment tool"
- HOMEPAGE="http://www.fsarchiver.org"
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="amd64 x86"
- IUSE="debug lzma lzo static"
- DEPEND="dev-libs/libgcrypt:0
- >=sys-fs/e2fsprogs-1.41.4
- lzma? ( >=app-arch/xz-utils-4.999.9_beta )
- lzo? ( >=dev-libs/lzo-2.02 )
- static? ( lzma? ( app-arch/xz-utils[static-libs] ) )"
- RDEPEND="${DEPEND}"
- src_prepare() {
- sed -i -e 's/^\([a-z]*_CFLAGS.*\)-ggdb/\1/' src/Makefile.am || die "seding
- failed"
- eautoreconf
- }
- src_configure() {
- econf $(use_enable lzma) \
- $(use_enable lzo) \
- $(use_enable static) \
- $(use_enable debug devel)
- }
|