fsarchiver-0.6.19.ebuild 824 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit autotools eutils
  5. DESCRIPTION="Flexible filesystem archiver for backup and deployment tool"
  6. HOMEPAGE="http://www.fsarchiver.org"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug lzma lzo static"
  12. DEPEND="dev-libs/libgcrypt:0
  13. >=sys-fs/e2fsprogs-1.41.4
  14. lzma? ( >=app-arch/xz-utils-4.999.9_beta )
  15. lzo? ( >=dev-libs/lzo-2.02 )
  16. static? ( lzma? ( app-arch/xz-utils[static-libs] ) )"
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. sed -i -e 's/^\([a-z]*_CFLAGS.*\)-ggdb/\1/' src/Makefile.am || die "seding
  20. failed"
  21. eautoreconf
  22. }
  23. src_configure() {
  24. econf $(use_enable lzma) \
  25. $(use_enable lzo) \
  26. $(use_enable static) \
  27. $(use_enable debug devel)
  28. }