magicrescue-1.1.9.ebuild 665 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Find deleted files in block devices"
  6. HOMEPAGE="http://www.itu.dk/people/jobr/magicrescue/"
  7. SRC_URI="http://www.itu.dk/people/jobr/magicrescue/release/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc x86"
  11. IUSE=""
  12. DEPEND="|| ( sys-libs/gdbm sys-libs/db )"
  13. RDEPEND="${DEPEND}"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-makefile.patch
  16. epatch "${FILESDIR}"/${P}-ldflags.patch
  17. tc-export CC
  18. }
  19. src_configure() {
  20. # Not autotools, just looks like it sometimes
  21. ./configure --prefix=/usr || die
  22. }