123456789101112131415161718192021222324252627282930 |
- # Copyright 1999-2013 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=4
- inherit eutils toolchain-funcs
- DESCRIPTION="Find deleted files in block devices"
- HOMEPAGE="http://www.itu.dk/people/jobr/magicrescue/"
- SRC_URI="http://www.itu.dk/people/jobr/magicrescue/release/${P}.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="amd64 ~ppc x86"
- IUSE=""
- DEPEND="|| ( sys-libs/gdbm sys-libs/db )"
- RDEPEND="${DEPEND}"
- src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
- epatch "${FILESDIR}"/${P}-ldflags.patch
- tc-export CC
- }
- src_configure() {
- # Not autotools, just looks like it sometimes
- ./configure --prefix=/usr || die
- }
|