collada_urdf-1.12.8.ebuild 590 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros/robot_model"
  5. KEYWORDS="~amd64 ~arm"
  6. ROS_SUBDIR=${PN}
  7. inherit ros-catkin
  8. DESCRIPTION="Tool to convert Unified Robot Description Format (URDF) documents into COLLADA documents"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. IUSE=""
  12. RDEPEND="
  13. dev-libs/boost:=
  14. dev-ros/angles
  15. dev-ros/collada_parser
  16. dev-ros/resource_retriever
  17. dev-ros/urdf
  18. dev-ros/geometric_shapes
  19. dev-ros/tf
  20. media-libs/assimp
  21. dev-libs/tinyxml
  22. dev-libs/collada-dom
  23. "
  24. DEPEND="${RDEPEND}"