monocam_settler-9999.ebuild 667 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. ROS_REPO_URI="https://github.com/ros-perception/calibration"
  5. CATKIN_HAS_MESSAGES=yes
  6. KEYWORDS="~amd64 ~arm"
  7. PYTHON_COMPAT=( python2_7 )
  8. ROS_SUBDIR=${PN}
  9. CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
  10. inherit ros-catkin
  11. DESCRIPTION="Listens on a ImageFeatures topic, and waits for the data to settle"
  12. LICENSE="BSD"
  13. SLOT="0"
  14. IUSE=""
  15. RDEPEND="
  16. dev-ros/actionlib[${PYTHON_USEDEP}]
  17. dev-ros/rosconsole
  18. dev-ros/roscpp_serialization
  19. dev-ros/settlerlib
  20. dev-libs/boost:=[threads]
  21. "
  22. DEPEND="${RDEPEND}
  23. test? ( dev-cpp/gtest )"