squashdelta-9999.ebuild 956 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. #if LIVE
  5. AUTOTOOLS_AUTORECONF=yes
  6. EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
  7. inherit git-r3
  8. #endif
  9. inherit autotools-utils
  10. DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
  11. HOMEPAGE="https://bitbucket.org/mgorny/squashdelta/"
  12. SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
  13. # uses public-domain murmurhash3
  14. LICENSE="BSD public-domain"
  15. SLOT="0"
  16. KEYWORDS="~amd64 ~x86"
  17. IUSE="lz4 +lzo"
  18. #if LIVE
  19. KEYWORDS=
  20. SRC_URI=
  21. #endif
  22. COMMON_DEPEND="
  23. lz4? ( app-arch/lz4:0= )
  24. lzo? ( dev-libs/lzo:2= )"
  25. RDEPEND="${COMMON_DEPEND}
  26. dev-util/xdelta:3"
  27. DEPEND=${COMMON_DEPEND}
  28. # SquashDelta does not make much sense without a compression algo.
  29. REQUIRED_USE="|| ( lz4 lzo )"
  30. src_configure() {
  31. local myeconfargs=(
  32. $(use_enable lz4)
  33. $(use_enable lzo)
  34. )
  35. autotools-utils_src_configure
  36. }