toppler-1.1.6.ebuild 639 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="Reimplementation of Nebulous using SDL"
  6. HOMEPAGE="http://toppler.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE="nls"
  12. RDEPEND="media-libs/libsdl[video]
  13. media-libs/sdl-mixer[vorbis]
  14. nls? ( virtual/libintl )"
  15. DEPEND="${RDEPEND}
  16. nls? ( sys-devel/gettext )"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-gentoo.patch
  19. }
  20. src_configure() {
  21. egamesconf $(use_enable nls)
  22. }
  23. src_install() {
  24. default
  25. prepgamesdirs
  26. }