12345678910111213141516171819202122232425262728293031323334 |
- # Copyright 1999-2014 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils games
- DESCRIPTION="Reimplementation of Nebulous using SDL"
- HOMEPAGE="http://toppler.sourceforge.net/"
- SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="amd64 ppc x86"
- IUSE="nls"
- RDEPEND="media-libs/libsdl[video]
- media-libs/sdl-mixer[vorbis]
- nls? ( virtual/libintl )"
- DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
- src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- }
- src_configure() {
- egamesconf $(use_enable nls)
- }
- src_install() {
- default
- prepgamesdirs
- }
|