12345678910111213141516171819202122232425262728293031323334353637383940414243444546 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="6"
- inherit multilib
- if [[ ${PV} == "9999" ]] ; then
- inherit git-r3 autotools
- EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}"
- else
- KEYWORDS="~amd64 ~arm ~mips ~x86"
- SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
- fi
- DESCRIPTION="Qualcomm MSM (Mobile Station Modem) Interface (QMI) modem protocol helper library"
- HOMEPAGE="https://cgit.freedesktop.org/libqmi/"
- LICENSE="LGPL-2"
- SLOT="0/5.1" # soname of libqmi-glib.so
- IUSE="doc +mbim static-libs"
- RDEPEND=">=dev-libs/glib-2.36
- mbim? ( >=net-libs/libmbim-1.14.0 )"
- DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- virtual/pkgconfig"
- [[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214
- src_prepare() {
- default
- [[ -e configure ]] || eautoreconf
- }
- src_configure() {
- econf \
- --disable-more-warnings \
- $(use_enable mbim mbim-qmux) \
- $(use_enable static{-libs,}) \
- $(use_enable {,gtk-}doc)
- }
- src_install() {
- default
- use static-libs || rm -f "${ED}/usr/$(get_libdir)/${PN}-glib.la"
- }
|