libqmi-9999.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit multilib
  5. if [[ ${PV} == "9999" ]] ; then
  6. inherit git-r3 autotools
  7. EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}"
  8. else
  9. KEYWORDS="~amd64 ~arm ~mips ~x86"
  10. SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
  11. fi
  12. DESCRIPTION="Qualcomm MSM (Mobile Station Modem) Interface (QMI) modem protocol helper library"
  13. HOMEPAGE="https://cgit.freedesktop.org/libqmi/"
  14. LICENSE="LGPL-2"
  15. SLOT="0/5.1" # soname of libqmi-glib.so
  16. IUSE="doc +mbim static-libs"
  17. RDEPEND=">=dev-libs/glib-2.36
  18. mbim? ( >=net-libs/libmbim-1.14.0 )"
  19. DEPEND="${RDEPEND}
  20. doc? ( dev-util/gtk-doc )
  21. virtual/pkgconfig"
  22. [[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214
  23. src_prepare() {
  24. default
  25. [[ -e configure ]] || eautoreconf
  26. }
  27. src_configure() {
  28. econf \
  29. --disable-more-warnings \
  30. $(use_enable mbim mbim-qmux) \
  31. $(use_enable static{-libs,}) \
  32. $(use_enable {,gtk-}doc)
  33. }
  34. src_install() {
  35. default
  36. use static-libs || rm -f "${ED}/usr/$(get_libdir)/${PN}-glib.la"
  37. }