socket_wrapper-1.1.7.ebuild 715 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-multilib
  5. DESCRIPTION="A library passing all socket communications through unix sockets"
  6. HOMEPAGE="https://cwrap.org/socket_wrapper.html"
  7. SRC_URI="https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  11. IUSE="test"
  12. DEPEND=""
  13. RDEPEND="${DEPEND}"
  14. # Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
  15. # Because of this we cannot use cmake-multilib_src_configure() here.
  16. multilib_src_configure() {
  17. local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
  18. cmake-utils_src_configure
  19. }