autoconf-wrapper-13.ebuild 844 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit multilib
  4. DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
  5. HOMEPAGE="https://www.gentoo.org/"
  6. SRC_URI=""
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  10. IUSE=""
  11. S=${WORKDIR}
  12. src_install() {
  13. exeinto /usr/$(get_libdir)/misc
  14. newexe "${FILESDIR}"/ac-wrapper-${PV}.sh ac-wrapper.sh || die
  15. dodir /usr/bin
  16. local x=
  17. for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
  18. dosym ../$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x} || die
  19. done
  20. }