ruby-ssl-9.ebuild 814 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. USE_RUBY="ruby21 ruby22 ruby23 ruby24"
  5. inherit ruby-ng
  6. DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
  7. SLOT="0"
  8. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  9. RDEPEND="
  10. ruby_targets_ruby21? ( dev-lang/ruby:2.1[ssl] )
  11. ruby_targets_ruby22? ( dev-lang/ruby:2.2[ssl] )
  12. ruby_targets_ruby23? ( dev-lang/ruby:2.3[ssl] )
  13. ruby_targets_ruby24? ( dev-lang/ruby:2.4[ssl] )
  14. "
  15. pkg_setup() { :; }
  16. src_unpack() { :; }
  17. src_prepare() { :; }
  18. src_compile() { :; }
  19. src_install() { :; }
  20. pkg_preinst() { :; }
  21. pkg_postinst() { :; }