123456789101112131415161718192021222324252627 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- USE_RUBY="ruby21 ruby22 ruby23 ruby24"
- inherit ruby-ng
- DESCRIPTION="Virtual ebuild for the Ruby OpenSSL bindings"
- SLOT="0"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- RDEPEND="
- ruby_targets_ruby21? ( dev-lang/ruby:2.1[ssl] )
- ruby_targets_ruby22? ( dev-lang/ruby:2.2[ssl] )
- ruby_targets_ruby23? ( dev-lang/ruby:2.3[ssl] )
- ruby_targets_ruby24? ( dev-lang/ruby:2.4[ssl] )
- "
- pkg_setup() { :; }
- src_unpack() { :; }
- src_prepare() { :; }
- src_compile() { :; }
- src_install() { :; }
- pkg_preinst() { :; }
- pkg_postinst() { :; }
|