vanilla-dmz-xcursors-0.4.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. MY_PN="Vanilla-DMZ"
  4. DESCRIPTION="Style neutral scalable cursor theme"
  5. HOMEPAGE="http://jimmac.musichall.cz/themes.php?skin=7"
  6. SRC_URI="http://jimmac.musichall.cz/zip/${P/-xcursors}.tar.bz2"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
  10. IUSE=""
  11. S=${WORKDIR}/${MY_PN}
  12. src_install() {
  13. insinto /usr/share/cursors/xorg-x11/${MY_PN}
  14. doins -r cursors || die "doins failed"
  15. }
  16. pkg_postinst() {
  17. elog "To use this set of cursors, edit or create the file ~/.Xdefaults"
  18. elog "and add the following line:"
  19. elog "Xcursor.theme: ${MY_PN}"
  20. elog
  21. elog "You can change the size by adding a line like:"
  22. elog "Xcursor.size: 48"
  23. elog
  24. elog "Also, to globally use this set of mouse cursors edit the file:"
  25. elog " /usr/share/cursors/xorg-x11/default/index.theme"
  26. elog "and change the line:"
  27. elog " Inherits=[current setting]"
  28. elog "to"
  29. elog " Inherits=${MY_PN}"
  30. elog
  31. elog "Note this will be overruled by a user's ~/.Xdefaults file."
  32. elog
  33. ewarn "If you experience flickering, try setting the following line in"
  34. ewarn "the Device section of your xorg.conf file:"
  35. ewarn " Option \"HWCursor\" \"false\""
  36. }