123456789101112131415161718192021222324252627282930313233343536373839404142 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- MY_PN="Vanilla-DMZ"
- DESCRIPTION="Style neutral scalable cursor theme"
- HOMEPAGE="http://jimmac.musichall.cz/themes.php?skin=7"
- SRC_URI="http://jimmac.musichall.cz/zip/${P/-xcursors}.tar.bz2"
- LICENSE="MIT"
- SLOT="0"
- KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86"
- IUSE=""
- S=${WORKDIR}/${MY_PN}
- src_install() {
- insinto /usr/share/cursors/xorg-x11/${MY_PN}
- doins -r cursors || die "doins failed"
- }
- pkg_postinst() {
- elog "To use this set of cursors, edit or create the file ~/.Xdefaults"
- elog "and add the following line:"
- elog "Xcursor.theme: ${MY_PN}"
- elog
- elog "You can change the size by adding a line like:"
- elog "Xcursor.size: 48"
- elog
- elog "Also, to globally use this set of mouse cursors edit the file:"
- elog " /usr/share/cursors/xorg-x11/default/index.theme"
- elog "and change the line:"
- elog " Inherits=[current setting]"
- elog "to"
- elog " Inherits=${MY_PN}"
- elog
- elog "Note this will be overruled by a user's ~/.Xdefaults file."
- elog
- ewarn "If you experience flickering, try setting the following line in"
- ewarn "the Device section of your xorg.conf file:"
- ewarn " Option \"HWCursor\" \"false\""
- }
|