1234567891011121314151617181920212223242526272829303132333435363738394041424344454647 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- inherit toolchain-funcs
- DESCRIPTION="Tiling window manager based on binary space partitioning"
- HOMEPAGE="https://github.com/baskerville/bspwm/"
- SRC_URI="https://github.com/baskerville/bspwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
- LICENSE="BSD-2"
- SLOT="0"
- KEYWORDS="~amd64 ~x86"
- IUSE="examples"
- DEPEND="
- x11-libs/libxcb
- x11-libs/xcb-util
- x11-libs/xcb-util-wm
- "
- RDEPEND="${DEPEND}
- x11-misc/sxhkd
- "
- src_compile() {
- emake PREFIX=/usr CC="$(tc-getCC)"
- }
- src_install() {
- emake DESTDIR="${D}" PREFIX=/usr install
- dodoc doc/{CONTRIBUTING,MISC,TODO}.md
- exeinto /etc/X11/Sessions
- newexe "${FILESDIR}"/${PN}-session ${PN}
- insinto /usr/share/xsessions
- doins contrib/freedesktop/bspwm.desktop
- insinto /etc/xdg/sxhkd
- doins examples/sxhkdrc
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- }
|