1234567891011121314151617181920212223242526272829303132333435363738394041 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit xfconf
- DESCRIPTION="Xfce4 screenshooter application and panel plugin"
- HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-screenshooter"
- SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
- IUSE="debug"
- RDEPEND=">=dev-libs/glib-2.16:=
- >=net-libs/libsoup-2.26:=
- >=x11-libs/gdk-pixbuf-2.16:=
- >=x11-libs/gtk+-2.16:2=
- dev-libs/libxml2:=
- x11-libs/libX11:=
- x11-libs/libXext:=
- x11-libs/libXfixes:=
- >=xfce-base/exo-0.6:=
- >=xfce-base/xfce4-panel-4.8:=
- >=xfce-base/libxfce4util-4.8:=
- >=xfce-base/libxfce4ui-4.8:="
- DEPEND="${RDEPEND}
- dev-util/intltool
- virtual/pkgconfig"
- pkg_setup() {
- XFCONF=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- $(xfconf_use_debug)
- --enable-xfixes
- )
- DOCS=( AUTHORS ChangeLog NEWS README TODO )
- }
|