xfce4-screenshooter-1.8.2.ebuild 1001 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="Xfce4 screenshooter application and panel plugin"
  6. HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-screenshooter"
  7. SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE="debug"
  12. RDEPEND=">=dev-libs/glib-2.16:=
  13. >=net-libs/libsoup-2.26:=
  14. >=x11-libs/gdk-pixbuf-2.16:=
  15. >=x11-libs/gtk+-2.16:2=
  16. dev-libs/libxml2:=
  17. x11-libs/libX11:=
  18. x11-libs/libXext:=
  19. x11-libs/libXfixes:=
  20. >=xfce-base/exo-0.6:=
  21. >=xfce-base/xfce4-panel-4.8:=
  22. >=xfce-base/libxfce4util-4.8:=
  23. >=xfce-base/libxfce4ui-4.8:="
  24. DEPEND="${RDEPEND}
  25. dev-util/intltool
  26. virtual/pkgconfig"
  27. pkg_setup() {
  28. XFCONF=(
  29. --docdir="${EPREFIX}"/usr/share/doc/${PF}
  30. $(xfconf_use_debug)
  31. --enable-xfixes
  32. )
  33. DOCS=( AUTHORS ChangeLog NEWS README TODO )
  34. }