12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849 |
- # Copyright 1999-2014 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils toolchain-funcs
- [[ ${PV} == 9999* ]] && inherit git-2
- DESCRIPTION="PDF plug-in for zathura"
- HOMEPAGE="http://pwmt.org/projects/zathura/"
- if ! [[ ${PV} == 9999* ]]; then
- SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
- fi
- EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
- EGIT_BRANCH="develop"
- LICENSE="ZLIB"
- SLOT="0"
- if ! [[ ${PV} == 9999* ]]; then
- KEYWORDS="~amd64 ~arm ~x86"
- else
- KEYWORDS=""
- fi
- IUSE=""
- RDEPEND="app-text/poppler:=[cairo]
- >=app-text/zathura-0.2.7
- x11-libs/cairo:="
- DEPEND="${RDEPEND}
- virtual/pkgconfig"
- pkg_setup() {
- myzathuraconf=(
- CC="$(tc-getCC)"
- LD="$(tc-getLD)"
- VERBOSE=1
- DESTDIR="${D}"
- )
- }
- src_compile() {
- emake "${myzathuraconf[@]}"
- }
- src_install() {
- emake "${myzathuraconf[@]}" install
- dodoc AUTHORS
- }
|