123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- # this ebuild is only for the libjpeg.so.8 SONAME for ABI compat
- inherit eutils libtool toolchain-funcs multilib-minimal
- DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
- HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
- SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz"
- LICENSE="IJG"
- SLOT="8"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- IUSE=""
- RDEPEND="!=media-libs/jpeg-8*:0
- !<media-libs/libjpeg-turbo-1.3.0-r2
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r5
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
- DEPEND="${RDEPEND}"
- DOCS=""
- src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch \
- "${FILESDIR}"/${P}-CVE-2013-6629.patch
- elibtoolize
- }
- multilib_src_configure() {
- # Fix building against this library on eg. Solaris and DragonFly BSD, see:
- # http://mail-index.netbsd.org/pkgsrc-bugs/2010/01/18/msg035644.html
- local ldverscript=
- [[ ${CHOST} == *-solaris* ]] && ldverscript="--disable-ld-version-script"
- ECONF_SOURCE=${S} \
- econf \
- --disable-static \
- --enable-maxmem=64 \
- ${ldverscript}
- }
- multilib_src_compile() {
- emake libjpeg.la
- }
- multilib_src_install() {
- newlib.so .libs/libjpeg.so.8.4.0 libjpeg.so.8
- }
|