1234567891011121314151617181920212223242526272829303132 |
- # Copyright 1999-2012 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- inherit toolchain-funcs
- DESCRIPTION="Simple X selection printer"
- HOMEPAGE="http://tools.suckless.org/x/sselp"
- SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
- LICENSE="MIT"
- SLOT="0"
- KEYWORDS="~amd64 hppa ~ppc ~ppc64 x86"
- DEPEND="x11-libs/libX11"
- RDEPEND="${DEPEND}"
- src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "s|^CFLAGS = -std=c99 -pedantic -Wall -Os|CFLAGS += -std=c99 -pedantic -Wall|" \
- -e "s|^LDFLAGS = -s|LDFLAGS +=|" \
- -e "s|^CC = cc|CC = $(tc-getCC)|" \
- config.mk || die "sed failed"
- }
- src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
- dodoc README
- }
|