isomaster-1.3.5.ebuild 762 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Graphical CD image editor for reading, modifying and writing ISO images"
  6. HOMEPAGE="http://littlesvr.ca/isomaster"
  7. SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND=">=x11-libs/gtk+-2:2"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_prepare() {
  16. epatch "${FILESDIR}"/${P}-ldflags.diff
  17. }
  18. src_configure() { :; }
  19. src_compile() {
  20. tc-export CC
  21. emake PREFIX="/usr" || die "emake failed"
  22. }
  23. src_install() {
  24. emake PREFIX="/usr" DESTDIR="${D}" install || die "emake install failed"
  25. dodoc {CHANGELOG,CREDITS,README,TODO}.TXT
  26. }