anthy-ss-9026.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2007 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit elisp-common eutils
  4. IUSE="emacs"
  5. MY_P="${P/-ss/}"
  6. DESCRIPTION="Anthy -- free and secure Japanese input system"
  7. HOMEPAGE="http://anthy.sourceforge.jp/"
  8. SRC_URI="mirror://sourceforge.jp/anthy/25984/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
  11. SLOT="0"
  12. S="${WORKDIR}/${MY_P}"
  13. DEPEND="!app-i18n/anthy
  14. emacs? ( virtual/emacs )"
  15. src_unpack() {
  16. unpack ${A}
  17. cd "${S}"
  18. local cannadicdir=/var/lib/canna/dic/canna
  19. if has_version 'app-dicts/canna-2ch'; then
  20. einfo "Adding nichan.ctd to anthy.dic."
  21. sed -i /placename/a"read ${cannadicdir}/nichan.ctd" \
  22. mkworddic/dict.args.in
  23. fi
  24. }
  25. src_compile() {
  26. local myconf
  27. use emacs || myconf="EMACS=no"
  28. econf ${myconf} || die
  29. emake || die
  30. }
  31. src_install() {
  32. emake DESTDIR="${D}" install || die
  33. use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
  34. dodoc AUTHORS DIARY NEWS README ChangeLog
  35. docinto doc
  36. rm doc/Makefile*
  37. dodoc doc/*
  38. }
  39. pkg_postinst() {
  40. use emacs && elisp-site-regen
  41. }
  42. pkg_postrm() {
  43. use emacs && elisp-site-regen
  44. }