12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273 |
- # Copyright 1999-2007 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- inherit elisp-common eutils
- IUSE="emacs"
- MY_P="${P/-ss/}"
- DESCRIPTION="Anthy -- free and secure Japanese input system"
- HOMEPAGE="http://anthy.sourceforge.jp/"
- SRC_URI="mirror://sourceforge.jp/anthy/25984/${MY_P}.tar.gz"
- LICENSE="GPL-2"
- KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
- SLOT="0"
- S="${WORKDIR}/${MY_P}"
- DEPEND="!app-i18n/anthy
- emacs? ( virtual/emacs )"
- src_unpack() {
- unpack ${A}
- cd "${S}"
- local cannadicdir=/var/lib/canna/dic/canna
- if has_version 'app-dicts/canna-2ch'; then
- einfo "Adding nichan.ctd to anthy.dic."
- sed -i /placename/a"read ${cannadicdir}/nichan.ctd" \
- mkworddic/dict.args.in
- fi
- }
- src_compile() {
- local myconf
- use emacs || myconf="EMACS=no"
- econf ${myconf} || die
- emake || die
- }
- src_install() {
- emake DESTDIR="${D}" install || die
- use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
- dodoc AUTHORS DIARY NEWS README ChangeLog
- docinto doc
- rm doc/Makefile*
- dodoc doc/*
- }
- pkg_postinst() {
- use emacs && elisp-site-regen
- }
- pkg_postrm() {
- use emacs && elisp-site-regen
- }
|