fbterm-1.7-r2.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit autotools-utils
  5. DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
  6. HOMEPAGE="https://fbterm.googlecode.com/"
  7. SRC_URI="https://fbterm.googlecode.com/files/${P}.0.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~arm64 ~x86"
  11. IUSE="caps gpm video_cards_vesa"
  12. RDEPEND="caps? ( sys-libs/libcap )
  13. gpm? ( sys-libs/gpm )
  14. video_cards_vesa? ( dev-libs/libx86 )
  15. media-libs/fontconfig
  16. media-libs/freetype:2"
  17. DEPEND="${RDEPEND}
  18. sys-libs/ncurses
  19. virtual/pkgconfig"
  20. AUTOTOOLS_IN_SOURCE_BUILD=1
  21. DOCS=( AUTHORS NEWS README )
  22. PATCHES=(
  23. "${FILESDIR}"/${P}-gcc6.patch
  24. )
  25. src_configure() {
  26. local myeconfargs=(
  27. $(use_enable gpm)
  28. $(use_enable video_cards_vesa vesa)
  29. )
  30. autotools-utils_src_configure
  31. }
  32. src_install() {
  33. autotools-utils_src_install
  34. $(type -P tic) -o "${ED}/usr/share/terminfo/" \
  35. "${S}"/terminfo/fbterm || die "Failed to generate terminfo database"
  36. if use caps; then
  37. setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/fbterm
  38. else
  39. fperms u+s /usr/bin/fbterm
  40. fi
  41. }
  42. pkg_postinst() {
  43. einfo
  44. einfo " ${PN} won't work with vga16fb. You have to use other native"
  45. einfo " framebuffer drivers or vesa driver."
  46. einfo " See ${EPREFIX}/usr/share/doc/${P}/README for details."
  47. einfo " To use ${PN}, ensure you are in video group."
  48. einfo " To input CJK merge app-i18n/fbterm-ucimf"
  49. einfo
  50. }