123456789101112131415161718192021222324252627282930313233 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=4
- DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
- HOMEPAGE="https://code.google.com/p/libhangul/"
- SRC_URI="https://libhangul.googlecode.com/files/${P}.tar.gz"
- LICENSE="LGPL-2.1"
- SLOT="0"
- KEYWORDS="amd64 ~ppc ppc64 x86"
- IUSE="nls static-libs test"
- RDEPEND="nls? ( virtual/libintl )"
- DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( dev-libs/check )"
- DOCS="AUTHORS ChangeLog NEWS README"
- src_configure() {
- econf \
- $(use_enable nls) \
- $(use_enable static-libs static)
- }
- src_install() {
- default
- rm -f "${ED}"/usr/lib*/libhangul.la
- }
|