libhangul-0.1.0.ebuild 717 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="libhangul is a generalized and portable library for processing hangul"
  5. HOMEPAGE="https://code.google.com/p/libhangul/"
  6. SRC_URI="https://libhangul.googlecode.com/files/${P}.tar.gz"
  7. LICENSE="LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~ppc ppc64 x86"
  10. IUSE="nls static-libs test"
  11. RDEPEND="nls? ( virtual/libintl )"
  12. DEPEND="${RDEPEND}
  13. virtual/pkgconfig
  14. nls? ( sys-devel/gettext )
  15. test? ( dev-libs/check )"
  16. DOCS="AUTHORS ChangeLog NEWS README"
  17. src_configure() {
  18. econf \
  19. $(use_enable nls) \
  20. $(use_enable static-libs static)
  21. }
  22. src_install() {
  23. default
  24. rm -f "${ED}"/usr/lib*/libhangul.la
  25. }