12345678910111213141516171819202122232425262728293031323334 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit cmake-utils
- DESCRIPTION="A YAML parser and emitter in C++"
- HOMEPAGE="https://github.com/jbeder/yaml-cpp"
- SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
- LICENSE="MIT"
- SLOT="0"
- KEYWORDS="amd64 ~arm ~hppa ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
- IUSE=""
- DEPEND=">=dev-libs/boost-1.49.0-r2"
- RDEPEND="${DEPEND}"
- src_prepare() {
- sed -i \
- -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
- yaml-cpp.pc.cmake || die
- cmake-utils_src_prepare
- }
- src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- )
- cmake-utils_src_configure
- }
|