12345678910111213141516171819202122232425262728293031323334353637383940 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- inherit gnome2
- DESCRIPTION="A calculator application for GNOME"
- HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
- LICENSE="GPL-2"
- SLOT="0"
- IUSE=""
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
- COMMON_DEPEND="
- >=dev-libs/glib-2.40:2
- dev-libs/libxml2:2
- dev-libs/mpfr:0
- dev-libs/mpc
- >=net-libs/libsoup-2.42:2.4
- >=x11-libs/gtk+-3.19.3:3
- >=x11-libs/gtksourceview-3.15.1:3.0
- "
- RDEPEND="${COMMON_DEPEND}
- !<gnome-extra/gnome-utils-2.3
- !gnome-extra/gcalctool
- "
- DEPEND="${COMMON_DEPEND}
- app-text/yelp-tools
- >=dev-util/intltool-0.50
- sys-devel/gettext
- virtual/pkgconfig
- "
- src_configure() {
- gnome2_src_configure \
- --disable-static \
- VALAC=$(type -P true)
- }
|