gnome-calculator-3.23.91.ebuild 833 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="A calculator application for GNOME"
  6. HOMEPAGE="https://wiki.gnome.org/Apps/Calculator"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. IUSE=""
  10. KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. COMMON_DEPEND="
  12. >=dev-libs/glib-2.40:2
  13. dev-libs/libxml2:2
  14. dev-libs/mpfr:0
  15. dev-libs/mpc
  16. >=net-libs/libsoup-2.42:2.4
  17. >=x11-libs/gtk+-3.19.3:3
  18. >=x11-libs/gtksourceview-3.15.1:3.0
  19. "
  20. RDEPEND="${COMMON_DEPEND}
  21. !<gnome-extra/gnome-utils-2.3
  22. !gnome-extra/gcalctool
  23. "
  24. DEPEND="${COMMON_DEPEND}
  25. app-text/yelp-tools
  26. >=dev-util/intltool-0.50
  27. sys-devel/gettext
  28. virtual/pkgconfig
  29. "
  30. src_configure() {
  31. gnome2_src_configure \
  32. --disable-static \
  33. VALAC=$(type -P true)
  34. }