gmpc-shout-0.20.0.ebuild 728 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=3
  4. DESCRIPTION="This plugin calls ogg123 and points it at mpd's shoutstream"
  5. HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_SHOUT"
  6. SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 x86"
  10. IUSE="nls"
  11. RDEPEND=">=media-sound/gmpc-${PV}
  12. media-sound/vorbis-tools[ogg123]
  13. dev-libs/libxml2
  14. x11-libs/cairo"
  15. DEPEND="${RDEPEND}
  16. virtual/pkgconfig
  17. nls? ( dev-util/intltool
  18. sys-devel/gettext )"
  19. src_configure() {
  20. econf \
  21. --disable-dependency-tracking \
  22. $(use_enable nls)
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" install || die
  26. find "${ED}" -name "*.la" -delete || die
  27. }