123456789101112131415161718192021222324252627282930313233343536373839 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils autotools
- DESCRIPTION="Dymo SDK for LabelWriter/LabelManager printers"
- HOMEPAGE="https://newellrubbermaid.secure.force.com/dymopkb"
- SRC_URI="http://download.dymo.com/Download%20Drivers/Linux/Download/${P}.tar.gz"
- S="${WORKDIR}/${P}.5"
- LICENSE="GPL-2"
- SLOT="0"
- IUSE="test"
- KEYWORDS="~amd64 ~x86"
- RDEPEND="net-print/cups"
- DEPEND="${RDEPEND}
- test? ( dev-util/cppunit )"
- # tests fail but needs to be investigated
- RESTRICT=test
- src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.0-cxxflags.patch
- eautoreconf
- }
- DOCS=( AUTHORS README ChangeLog docs/SAMPLES )
- src_install() {
- default
- insinto /usr/share/doc/${PF}
- doins docs/*.{txt,rtf,ps,png}
- }
|