dymo-cups-drivers-1.4.0.ebuild 779 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils autotools
  5. DESCRIPTION="Dymo SDK for LabelWriter/LabelManager printers"
  6. HOMEPAGE="https://newellrubbermaid.secure.force.com/dymopkb"
  7. SRC_URI="http://download.dymo.com/Download%20Drivers/Linux/Download/${P}.tar.gz"
  8. S="${WORKDIR}/${P}.5"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE="test"
  12. KEYWORDS="~amd64 ~x86"
  13. RDEPEND="net-print/cups"
  14. DEPEND="${RDEPEND}
  15. test? ( dev-util/cppunit )"
  16. # tests fail but needs to be investigated
  17. RESTRICT=test
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${PN}-1.2.0-cxxflags.patch
  20. eautoreconf
  21. }
  22. DOCS=( AUTHORS README ChangeLog docs/SAMPLES )
  23. src_install() {
  24. default
  25. insinto /usr/share/doc/${PF}
  26. doins docs/*.{txt,rtf,ps,png}
  27. }