12345678910111213141516171819202122232425262728293031323334353637383940414243 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- inherit multilib toolchain-funcs eutils multilib-minimal
- MY_P="${P//_/-}"
- DESCRIPTION="SELinux binary policy representation library"
- HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
- SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/${MY_P}.tar.gz"
- LICENSE="GPL-2"
- SLOT="0"
- KEYWORDS="amd64 ~arm ~arm64 ~mips x86"
- IUSE=""
- DEPEND=""
- RDEPEND=""
- S="${WORKDIR}/${MY_P}"
- # tests are not meant to be run outside of the
- # full SELinux userland repo
- RESTRICT="test"
- src_prepare() {
- epatch_user
- multilib_copy_sources
- }
- multilib_src_compile() {
- tc-export RANLIB;
- LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
- emake AR="$(tc-getAR)" CC="$(tc-getCC)"
- }
- multilib_src_install() {
- LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
- emake DESTDIR="${D}" install
- }
|