libsepol-2.5.ebuild 985 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit multilib toolchain-funcs eutils multilib-minimal
  5. MY_P="${P//_/-}"
  6. DESCRIPTION="SELinux binary policy representation library"
  7. HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
  8. SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~arm ~arm64 ~mips x86"
  12. IUSE=""
  13. DEPEND=""
  14. RDEPEND=""
  15. S="${WORKDIR}/${MY_P}"
  16. # tests are not meant to be run outside of the
  17. # full SELinux userland repo
  18. RESTRICT="test"
  19. src_prepare() {
  20. epatch_user
  21. multilib_copy_sources
  22. }
  23. multilib_src_compile() {
  24. tc-export RANLIB;
  25. LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
  26. emake AR="$(tc-getAR)" CC="$(tc-getCC)"
  27. }
  28. multilib_src_install() {
  29. LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
  30. emake DESTDIR="${D}" install
  31. }